
RESUMIX/CPDSS User’s Guide to Filling Jobs 
AFPC/DPCXT, Revised October 2003 
 

4-1

Chapter 4 - Job Analysis and Job Analysis 
Promotion Plan Template Development                       
 
The Job Analysis Promotion Plan Template is the tool used to rate and rank applicants.  Before creating a 
new template, check the Template Library for a Standard Template that matches the criteria of the 
position being filled. A Standard Template can be identified by the “ST” in the title.  A new template 
should only be created when an approved template cannot be found that matches the criteria for the 
position being filled. 
  

From the Main CPDSS screen select the “Job Analysis Promotion Plan Template” button   .   
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
OR initiate the Job Analysis Promotion Plan Template using the Start-Up menu as shown below:  (the 
user will be prompted for their login and password) 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
NOTE:  From the Start-Up menu, the entire CPDSS program menu may be opened or one specific menu 
item may be opened.  The system will still prompt the user for a login and password even if one specific 
menu item is selected. 
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Below is a screen shot of the Job Analysis Promotion Plan Template window.  From this window a new 
Job Analysis Template may be created or the template library may be opened to find an existing 
template.   
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To begin, let’s discuss the Main Menu Bar options and the Tool Bar buttons.   Understanding the 
functions that these buttons perform will make using CPDSS easier. 
 
 

This button Enables you to…. The equivalent Main Menu 
command is …… 

 Create a New Job Analysis 
Promotion Plan Template 

File> New Job Analysis Promotion 
Plan Template 

 
 

Open up an existing Job 
Analysis Promotion Plan 
Template 

File > Open Job Analysis Promotion 
Plan Template 

 
 
 

Save the Job Analysis 
Promotion Plan Template. 
 
 
 

File > Save Job Analysis Promotion 
Plan Template 

 Generate a report in a 
separate window detailing the 
attributes of the template. 

File > Report 

 Create or edit a new or 
existing Job Analysis 
Information Window 

Edit > Edit Job Analysis Information 

 Delete the current Job 
Analysis Promotion Plan 
Template. 
 

File > Delete Job Analysis Promotion 
Plan Template 

 Information about the Job 
Analysis Promotion Plan 
Template 

Help > About Job Analysis 
Promotion Plan  

 Acquire information on any 
part of the template where the 
question mark is placed. 

Help> Help Topics 
 

N/A N/A View > Tool Bar or Status Bar 
 

N/A N/A File > Save Template As….. 
Note:  When this function is used, 
the name of the original template will 
populate the notes section of the 
new template.  

N/A N/A Change Status > Test to Approved 
or > Approved to Archived.  This 
functionality will not be granted to all 
staffing specialist. 
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The Template Naming Convention 
 
A standard naming convention has been identified from Air Force to be used when naming all Job 
Analysis Templates.  The template name must be all CAPITAL LETTERS and should have dashes 
between each field.  The naming convention is as follow:  
 
• Internal/External Staffing:  Pay Plan (2) - Occ Series (4) - Grade (2) - INT (Internal) or EXT 

(External) (3) - Primary Skill of Position (3) - ST for Standard or BASE ID (2)-TITLE  (Example: 
GS-0201-11-EXT-AGV-ST-PERSONNEL MANAGEMENT SPEC ).  There is a team of specialist 
identified to develop Standard Templates that can be used to rate and/or rank your match list of 
candidates.  Standard templates will use the same naming convention except the letters ”ST” will be 
used instead of the Base ID.  This will help to find the template at a later date. 

• DEU:   Follow instructions in the DEU Procedures/Training Guide.  (GS/0318/DEU/4V/DPM) 
 
NOTE: 
AFMC and USAFE will create templates for MAJCOM wide use, these templates will have the 
MAJCOM ID inserted where the “BASE ID” code is identified on the templates: 
USAFE example   GS-0201-11-INT-AGV-3K-PERSONNEL MANAGEMENT SPEC 
AFMC example     GS-0201-11-INT-AGV-1M-PERSONNEL MANAGEMENT SPEC  
 
 
Choosing a Career Program 
 

• Click the drop down arrow beside the Career Program Name field to display a list of valid Career 
Program Identifiers. 

• Click on the desired Career Program.  If not associated with a Career program, select “Unknown”. 
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Template Status 
 
Indicates the current status of the template and the date the last modification 
was made to the template.    A template can have one of three statuses as 
described below:   
 
  Test:   When a template is initially created it is in a test status.   A 
template in a test status may be modified as often as necessary, but only by the 
creator.  Templates in a test status are assumed to be in a developmental stage 
and should not be used to rate/rank candidates.   
 
 Approved:   A test template may be promoted to an APPROVED 
status only by an individual with the appropriate permission.   Approved 
templates are available for use by everyone. 
 
 Archived:   Approved templates are promoted to ARCHIVED when 
they are no longer useful for rating/ranking candidates (i.e. skill code changes, 
etc) but, need to be retained as part of the case file/audit trail  (in case of 
litigation).  An Archived template can never be used to rate and rank 
candidates. 
 
 Last Modified:  This identifies the date and time of the last 
modification to the template.   
 
Created:   This identifies the creator of the template and the date and time the 
template was created. 
 
Approved:    This identifies the person who approved the template and the date 
and time the template was approved.  
 
Archived:  This identifies the person who archived the template and the date 
and time the template was archived. 
 
Status Bar 
 
 
 
 
 
 
The status bar is displayed at the bottom of the Job Analysis Promotion Plan main window.  To display or 
hide the status bar, select View > Status Bar. 
 
The left side of the status bar describes actions from menu items as the arrow keys are used to navigate 
through the menu items.  This area also shows messages that describe the actions of the Tool Bar 
buttons as you run your mouse over them.  The status indicator will identify the current action being 
performed by the Job Analysis Promotion Plan program.   
 
The right side of the status bar indicates the various databases to which the Job Analysis Promotion Plan 
interacts.  Each ball is connected to a specific database and changes colors to alert the user of a  
connection or a disconnection between the systems.  The various colors are described below: 
 
Indicator Description 
GRAY  The database is not currently connected. 
YELLOW The database connection is currently in progress. 
GREEN  The database connection has been achieved and is currently opened. 
RED  The database connection was lost or could not be achieved.

Resumix 
Database 

Experience History 
Database 

CPDSS 
Database 

DCPDS 
Database 
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Opening an Existing Job Analysis Promotion Plan Template 
 
Click on the Yellow Open Folder or use the Main Menu command: File> Open Job Analysis Promotion 
Plan Template.  A list of all Templates will appear.    
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
To open a template, click the left mouse button on the desired template name and click the OK button at 
the bottom of the page.  A second way to open a template is to double click on the selected (highlighted) 
template name.  Click the Cancel button to cancel the action of opening a Job Analysis Promotion Plan 
Template.  The template list may be sorted by any of the columns; simply by clicking the left mouse 
button in the desired column header.  An up arrow on the column header will indicate that the list is 
sorted in ascending order and a down arrow on the column header will indicate that the list is sorted in 
descending order.  Click on the column header to toggle between ascending and descending order.   
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Filtering Templates 
 
A filter option is available to narrow the templates display in the list to only those templates that match 
specific criteria entered in the Template Filter window.   
 
To filter the template library, click the “Filter Job Analysis Promotion Plan Templates” check box located 
in the upper left-hand corner of the open Job Analysis Promotion Plan Template window.  The Template 
Filter window will appear.  This window has three options for narrowing the list of templates using 
wildcard patterns and/or template status matches.  To refine the list using wildcard patterns type in the 
entire name or a partial name with a wildcard pattern for the career program, and/or the template name, 
and/or the template owner.  There are two special characters that may be used as wildcards: 
 

%:  Place a percent sign in the value to match zero or more characters.  For example CA% 
could be used to match CAT, CART, and CALIFORNIA.  Also CA%T could be used to match CAT, 
CART, CARPET, etc. 

 
_:  Place an underscore in the value to match a single character.  For example _AT could be 
used to match BAT, CAT, MAT, etc. 
 

A search may further filter the templates by clicking the checkbox on one or all of the “Template Status 
Match” field(s).  If more than one template status is selected, they will have the effect of being OR’ed 
together.  For example; if TEST and APPROVED are checked, then all templates with a status of TEST 
or APPROVED will be retrieved.   Clicking the left mouse button on a status field will toggle the check 
mark on and off. 
 
Selecting the OK button will return the user to the Open Job Analysis Promotion Plan Template window 
with the list of templates that matched the filtered criteria.  Selecting the Cancel button will cancel the 
filtering operation and return the user to the Open Job Analysis Promotion Plan Template window. 
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Changing the Status of the Template: 
 
Depending on the user’s privileges, the template status may be changed by selecting “Change Status” 
from the main menu.  The dialog box below will appear.  This will identify the template’s current status 
and allow the user to make changes.   From this area the template can be changed from Test to 
Approved or Approved to Archived.   

  
If needed, additional comments or notes may be added.  When finished click <OK> to change the status 
of the template.   This information is displayed in the Status Area on the main window of the Job Analysis 
Promotion Plan. 
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Creating a Job Analysis/Job Analysis Promotion Plan Template Report 
 

To create the Job Analysis click on the Edit Job Analysis button   .  The Job Analysis Information 
window will display.   
 
Complete the field for “Name of Creating Staffing Specialist” by typing the name or by selecting from the 
drop-down menu.  The “Name of the Subject Matter Expert” must be typed; there is not a drop down 
menu available.   
 
Click on the <Copy from Resumix Requisition Job Description> button.  
 
 

 
 
 
 
 If Resumix is active on your desktop, and the requisition is open from which the job analysis will 
be created, the system will automatically bring up that requisition.  
 
             If Resumix is not active on your desktop the system will bring up the entire Resumix Requisition 
Library.  The requisitions may be sorted by clicking in the column header; the arrow indicates whether you 
are sorting in ascending or descending order.  Highlight the requisition to use and click “OK”.   
 
Note:  There is no a filter option for this screen. 
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Once the requisition has been identified from which to create the Job Analysis, the screen below will 
open in CPDSS.  This screen pulls all the information that is currently in the “Job – Description” tab of 
the Resumix Requisition.   
 
At this point, if another requisition is needed, or the user pulled the incorrect requisition, click the 
“Choose Other Requisition(s) button.  This will return the user to the Resumix Requisition Library and 
allow the user to choose a different requisition. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
There are three sets of buttons located at the bottom of the window to use for the creation of the Job 
Analysis. 
 

(1)   Best Qualified Description   
 
(2)   Major Job Requirements 
 
(3)   Knowledge, Skills, and Abilities (KSAs). 
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To add information to the Major Job Requirements area, highlight the information to be added then click 
the <Add> button located below the “Major Job Requirements.” 
 
To add information to the Knowledge, Skills and Abilities area on the Job Analysis, highlight the 
information to be added then click <Add> located below “Knowledge, Skills and Abilities (KSAs).” 
 
To add information to the Best Qualified Description area on the Job Analysis, highlight the information to 
be added then click <Add> located below “Best Qualified Description.”   
 
Click <DONE> when all the information required has been added.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
At this point the system returns to the Job Analysis Information window.  From here, additional 
information may be manually inserted (ensure spelling is accurate) in the Job Analysis.  After all 
information has been added, click <OK> to return to the main Job Analysis Promotion Plan Template 
window. 
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Choosing a Template Element 
 
At the bottom of the screen there are several Element options to choose.  The <OPT9> tab is used to fill 
external positions and the <INTERNAL> tab is used to fill internal positions.  (Note:  If filling a DEU job 
use <OPT9> and <VET>.  The remaining elements are reserved for Career Program use.   This guide 
covers creating templates for External, Internal and DEU fills.   
 
 
ELEMENT BUTTONS:  Each button has been provided based on specific restrictions established for the 
template to process.   Either a single element may be used or multiple elements may be attached to a Job 
Analysis Promotion Plan.  The user sets certain attributes of the element including whether or not the 
element(s) will be active, the maximum points allowed for the element, and the rules and restrictions for 
the element.  (See Attachment 1, at the end of this chapter, for a description of each Element Button). 
 
 

 
 
 
 
 
 
 
 
 



RESUMIX/CPDSS User’s Guide to Filling Jobs 
AFPC/DPCXT, Revised October 2003 
 

4-13

External Recruitment - (OPT9) 
 
This section covers the steps used to complete a Job Analysis Promotion Plan Template using Resumix 
grammar/skills. 
 
Select  <OPT 9> (from the Template Element area) to display the screen shown below. 
 
To complete the Job Related Skills window: 
 
Step 1:  Creating Element Rules: 
 

 
• Assign - This field identifies the point value that should be assigned to the element rule.   
 
• Points for – This field allows the user to choose how many occurrences of  Resumix skills a 

candidate must match in order for the point value assigned to be applied.  Select from the drop-
down menu to access the following options: 

 
o ALL – This allows the point value to be assigned for the rule only if all of the Resumix skills 

selected are matched. 
 
o ANY ONE – This allows the point value to be assigned for the rule if any Resumix skill 

selected is matched. 
 
o NUMBER – A number can be placed in this field instead of one of the choices from the drop-

down menu.  The number represents how many skills must be matched by the applicant in 
order for the applicant to receive the point value for this rule.   (EX: a “3” in this area means 
the candidate must have 3 out of all the skills listed to receive the point value assigned) 

 
 
          
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Step 1 

Step 2 
See below 
for more 
info 

A NUMBER can 
be placed in this 
field instead of 
making a 
selection from the 
menu.
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Step 2:  Importing Resumix Skills - Click <Import Skills List>.  The following options Menu will appear: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
For illustration purposes, the Extract from Major Job Requirements (MJRs) option will be selected. To 
begin the process, simply click on the option desired.  CPDSS will take the information from the MJRs 
area of the job analysis and process the information through the Resumix Knowledge Base to extract the 
skills and insert them in the value field.  To insure a comprehensive list of skills in which to choose from, 
also extract skills from the Knowledge, Skills, and Abilities area (repeating the same procedure as above).  
These skills will be added to the skills area of the (OPT9) Window.  The system will not list the same skill 
more than once. 
 
Caution:  Extracting skills from the MJRs and KSA areas ensures the user a direct link to the Job 
Analysis.  If skills are extracted from the Open Resumix Requisition, Other Resumix Requisition or any of 
the other options available there may be skills used that are not directly linked to the Job Analysis.  To 
avoid this and maintain the validity of the ranking criteria, if additional skills are needed, return to the Job 
Analysis Template and type additional MJRs or KSA(s) relevant to the position being filled and re-extract 
skills. 
 
Step 3:  Click the down arrow on the value box.  A drop-down menu of Resumix skills extracted will be 
displayed. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Pulls skills from the job description area of 
the requisition that is open on your desktop. 

Provides a drop-down menu to select an 
unopened requisition.  Skills are pulled 
from the job description area of the 
requisition selected.   

Pulls skills from the MJRs or KSAs copied to the Job 
Analysis Promotion Plan Template. 

Provides a dialog box for typing or pasting 
text for extracting skills. 

 

Step 1 

Step 2

Step 3 
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Step 4:  Using Element Rule 1, select the appropriate Resumix skills that will identify candidates who may 
meet minimum qualifications/basic eligibility requirements for the position being filled. 
 
Step 5:  Repeat Steps 1 through 4 as necessary until you have an adequate amount of rules to identify 
candidates that meet: 
   
  Minimum Qualifications/ Basic Eligibility 
  Better Qualified 
  Best Qualified 
 
NOTES:   

1. The Element, Option 9 (OPT9), must contain a minimum of at least one Element Rule.  It is 
recommended that no more than five rules be used. 

2. To select multiple Resumix skills in a row, highlight the first desired skill, depress the 
‘shift’ key, and click the last desired skill.  All intervening skills will be selected. 

3. To deselect a skill, click a second time on the skill and the check will disappear. 
4. With each additional Element Rule, the objective is to build the rules to narrow down to 

identifying best-qualified candidates. 
 
Step 6:  Once the Element Rules are complete, place the point value assigned to the highest Element 
Rule in the Maximum Points field.  Ex: if 4 points is the highest value assigned then place a 4 in the field.  
Click on the “Use this element” checkbox.  A check mark will appear in the box.  This is an indicator of 
whether the element is active or inactive in the Job Analysis Promotion Plan Template (must be active for 
the template to work). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Step 4

Step 6 
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OR and AND Logic: 
 
The “OR Logic” is used as a substitution for one or all Element Rules and the “AND Logic” is used as a 
must have restriction for Element Rule(s) or for the OR Logic area.  Later in this topic we will explain how 
to apply the rules to one data field or to multiple data fields. 
 
The OR and the AND Logic blocks located at the bottom of the (OPT9) Window, consist of the following: 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
NOTE:  The “?” mark located at the top right hand corner of the screen can be use to obtain 
context help screens (like the ones seen above).  Click and drag” the “?” mark to any area on this 
screen to view the context help screens.    

(This is a partial list only) 
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Data Field: 
This allows the user to apply a restriction to a specific item(s).  This field extracts data from the tables 
located in the Resumix database.  (Example:  Typing Speed, Steno Speed etc).   See Attachment 2 (at 
the end of chapter 4) for a listing of options. 
 

Note:  The special selection **CLEAR RESTRICTION** will remove the restriction line 
from the element.  The entire restriction line will be deleted.  

 
Logical Operator: 
Select the desired operator to be applied to the Value field.  This selection must be completed prior to 
input of the Value Set. 
 
Value Set 
Select the appropriate value(s) from the drop-down list if the field is blue.  Otherwise, the value must be 
input manually.  See Restriction Value Set information in the above illustration. 
 
Apply To Rule for the “OR Logic” area. (OR Logic is used as Substitution) 
This allows the user to select the Element Rule(s) that the “OR Logic” applies to.  The restriction may be 
applied to one line number, multiple line numbers or ALL the element rules for which this “Data Field” will 
substitute.  Type the line number in the field, and press the Insert key to add the entered line number to 
the list. Repeat for each additional Element Rule.  Choose the ALL selection to apply the “OR Logic” to 
all of the Element Rule lines.   
 

 
 
 
Apply to Rule for the “AND Logic” area.   (AND Logic is a MANDATORY restriction) Values are 
entered in the same manner as the “OR Logic”.  The only major difference is in the Apply to Rule/OR 
Logic window. 
 
Apply To Rule/OR Logic 
This field allows you to apply “AND Logic” to the Element Rule(s), the “OR Logic” fields, or a 
combination of the two using one of the following: 
 

• To apply “AND Logic” to Element Rules, type an “R” plus the rule line number and press the 
Insert key. 

• To apply “AND Logic” to “OR Logic” statements, type an “O” plus the “OR Logic” line number and 
press the Insert key. 

• To apply “AND Logic” to all Element Rules select “RULE All” from the drop-down list. 
• To apply “AND Logic” to all “OR Logic” lines select “OR All” from the drop-down list. 
• Simply typing a numeric value will prompt the system to ask if you want to apply this restriction to 

the Element Rule area or the Or Logic area. 
 

 

 
 
Step 7:  Click <OK>.  This will return you to the Main Job Analysis Promotion Plan Template screen.  
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Saving the Job Analysis Promotion Plan Template 
 
Once the Job Analysis Promotion Plan Template is complete the template should be saved by: 
 

• Clicking File > Save Job Analysis Promotion Plan Template or  
 
 

• Clicking the Save button. 
 
 
Remember changes can be made to a template that is in a “Test” status, but only by the original creator.  
Once the template is in an approved or archived status, in order to make changes, the template must be 
copied.  To do this, select File > Save Template As, rename the template using the appropriate naming 
convention.  This will create a copy of the template in a test status that can then be modified for 
necessary changes.  
 
Entering Template Notes: 
 

• Place your cursor inside the Template Notes Box. 
• Type in the desired comments.  This box can be used to identify Qualification Requirements, 

Education Substitution, TIG, Physical Requirement, Quality of Experience, OPM Standard etc. or 
any other pertinent information. 

 
NOTE:  When the “Save Template As….” function is used, the system automatically generates a 
message identifying the original template from which it was created and deletes any notes that 
were on the original template.
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DEU Recruitment - (OPT9) and (VET) 
 
This section covers the steps used to complete a Job Analysis Promotion Plan Template using Resumix 
grammar/skills and Veterans Preference. 
 
Select  <OPT 9> (from the Template Element area) to display the screen shown below. 
 
To complete the Job Related Skills window: 
 
Step 1:  Creating Element Rules: 
 

 
• Assign - This field identifies the point value that should be assigned to the element rule.  (DEU 

has specific values that are assigned in this area) 
 
• Points for – This field allows the user to choose how many occurrences of  Resumix skills a 

candidate must match in order for the point value assigned to be applied.  Select from the drop-
down menu to access the following options: 

 
o ALL – This selection allows the point value to be assigned for the rule only if all of the 

Resumix skills selected are matched. 
 
o ANY ONE – This selection allows the point value to be assigned for the rule if any Resumix 

skill selected is matched. 
 
o NUMBER – A number can be placed in this field instead of one of the choices from the drop-

down menu.  The number represents how many skills must be matched by the applicant in 
order for the applicant to receive the point value for this rule.   (EX: a “3” in this area means 
the candidate must have 3 out of all the skills listed to receive the point value assigned) 

 
 
          
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Step 1 

Step 2 
See below 
for more 
info 

A NUMBER can 
be placed in this 
field instead of 
making a 
selection from the 
menu.
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Step 2:  Importing Resumix Skills - Click <Import Skills List>.  The following options Menu will appear: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
For illustration purposes, the Extract from Major Job Requirements (MJRs) option will be selected. To 
begin the process, simply click on the option desired.  CPDSS will take the information from the MJRs 
area of the job analysis and process the information through the Resumix Knowledge Base to extract the 
skills and insert them in the value field.  To insure a comprehensive list of skills in which to choose from, 
also extract skills from the Knowledge, Skills, and Abilities area (repeating the same procedure as above).  
These skills will be added to the skills area of the (OPT9) Window.  The system will not list the same skill 
more than once. 
 
Caution:  Extracting skills from the MJRs and KSA areas ensures the user a direct link to the Job 
Analysis.  If skills are extracted from the Open Resumix Requisition, Other Resumix Requisition or any of 
the other options available there may be skills used that are not directly linked to the Job Analysis.  To 
avoid this and maintain the validity of the ranking criteria, if additional skills are needed, return to the Job 
Analysis Template and type additional MJRs or KSA(s) relevant to the position being filled and re-extract 
skills. 
 
Step 3:  Click the down arrow on the value box.  A drop-down menu of Resumix skills extracted will be 
displayed.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Pulls skills from the job description area of 
the requisition that is open on your desktop. 

Provides a drop-down menu to select an 
unopened requisition.  Skills are pulled 
from the job description area of the 
requisition selected.   

Pulls skills from the MJRs or KSAs copied to the Job 
Analysis Promotion Plan Template. 

Provides a dialog box for typing or pasting 
text for extracting skills. 

 

Step 1 

Step 2

Step 3 
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Step 4:  Using Element Rule 1, select the appropriate Resumix skills that will identify candidates who may 
meet minimum qualifications/basic eligibility requirements for the position being filled. 
 
Step 5:  Repeat Steps 1 through 4 as necessary until you have an adequate amount of rules to identify 
candidates that meet: 
   
  Minimum Qualifications/ Basic Eligibility 
  Better Qualified 
  Best Qualified 
 
NOTES:   

1.  The Element, Option 9 (OPT9), must contain a minimum of at least one Element Rule.  It is 
recommended that no more than five rules be used. 
2.   To select multiple Resumix skills in row, highlight the first desired skill, depress the ‘shift’ key, and 
click the last desired skill.  All intervening skills should be selected. 
3.   To deselect a skill, click a second time on the skill and the check will disappear. 
4.   With each additional Element Rule, the objective is to build the rules to narrow down to best-
qualified candidates. 

 
Step 6:  Once the Element Rules are complete, place the point value assigned to the highest Element 
Rule in the Maximum Points field.  Ex: if 90 points is the highest value assigned then place a 90 in the 
field.  Click on the “Use this element” checkbox.  A check mark will appear in the box.  This is an indicator 
of whether the element is active or inactive in the Job Analysis Promotion Plan Template (must be active 
for the template to work). 
 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

Step 6

Step 04 
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OR and AND Logic: 
 
The “OR Logic” is used as a substitution for one or all Element Rules and the “AND Logic” is used as a 
must have restriction for Element Rule(s) or for the OR Logic area.  Later in this topic we will explain how 
to apply the rules to one data field or to multiple data fields. 
 
The OR and the AND Logic blocks located at the bottom of the (OPT9) Window, consist of the following: 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
NOTE:  The “?” mark located at the top right hand corner of the screen can be use to obtain 
context help screens (like the ones seen above).  Click and drag” the “?” mark to any area on this 
screen to view the context help screens. 
   

(This is a partial list only) 
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Data Field: 
This allows the user to apply a restriction to a specific item(s).  This field extracts data from the tables 
located in the Resumix database.  (Example:  Typing Speed, Steno Speed etc).   See Attachment 2 (at 
the end of chapter 4) for a listing of options. 
 

Note:  The special selection **CLEAR RESTRICTION** will remove the restriction line 
from the element.  The entire restriction line will be deleted.  

 
Logical Operator: 
Select the desired operator to be applied to the Value field.  This selection must be completed prior to 
input of the Value Set. 
 
Value Set 
Select the appropriate value(s) from the drop-down list if the field is blue.  Otherwise, the value must be 
ield.  See Restriction Value Set information in the above illustration. 
 
Apply To Rule for the “OR Logic” area. (OR Logic is used as a substitution) 
This field allows the user to select the Element Rule(s) that the “OR Logic” applies to.  The restriction 
may be applied to one line number, multiple line numbers or ALL the element rules for which this “Data 
Field” will substitute.  Type the line number in the field, and press the Insert key to add the entered line 
number to the list. Repeat for each additional Element Rule.  Choose the ALL selection to apply the “OR 
Logic” to all of the Element Rule lines.   
 

 
 
Apply to Rule for the “AND Logic” area.  (AND Logic is a MANDATORY restriction)  Values are 
entered in the same manner as the “OR Logic”.  The only major difference is in the Apply to Rule/OR 
Logic window. 
 
Apply To Rule/OR Logic 
This field allows you to apply “AND Logic” to the Element Rule(s), the “OR Logic” fields, or a 
combination of the two using one of the following: 
 

• To apply “AND Logic” to Element Rules, type an “R” plus the rule line number and press the 
Insert key. 

• To apply “AND Logic” to “OR Logic” statements, type an “O” plus the “OR Logic” line number and 
press the Insert key. 

• To apply “AND Logic” to all Element Rules select “RULE All” from the drop-down list. 
• To apply “AND Logic” to all “OR Logic” lines select “OR All” from the drop-down list. 
• Simply typing a numeric value will prompt the system to ask if you want to apply this restriction to 

the Element Rule area or the Or Logic area. 
 

 

 
 
 
Step 7:  Click <OK>.  This will return you to the Main Job Analysis Promotion Plan Template screen.
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Step 8:   DEU uses both the OPT 9 and the VET Templates.  The user must ensure that both elements 
are part of the Job Analysis Template and that both are active.   
 
Click the <VET> tab to display the following screen. 
 
  Click on the “Use this element?” checkbox.  A check mark will appear in the box.  This indicates 
the Veterans Preference (VET) element is active in the Job Analysis Promotion Plan Template. 
 
Step 9:  Click <OK>.  This will return you to the Main Job Analysis Promotion Plan Template screen. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The main screen should show both OPT 9 – JOB RELATED SKILLS (SKL3) and  (VET) VETERANS 
PREFERENCE (VET) active.  The GREEN “check mark” indicates the template is active. 
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Saving the Job Analysis Promotion Plan Template 
 
Once the Job Analysis Promotion Plan Template is complete the template should be saved by: 
 

• Clicking File > Save Job Analysis Promotion Plan Template or  
 
 

• Clicking the Save button. 
 
 
Remember changes can  be made to a template that is in a “Test” status, but only by the original creator.  
Once the template is in an approved or archived status, in order to make changes, the template must be 
copied.  To do this, select File > Save Template As, rename the template using the appropriate naming 
convention.  This will create a copy of the template in a test status that can then be modified for 
necessary changes.  
 
 
Entering Template Notes: 
 

• Place your cursor inside the Template Notes Box. 
• Type in the desired comments.  This box can be used to identify Qualification Requirements, 

Education Substitution, TIG, Physical Requirement, Quality of Experience, OPM Standard etc. or 
any other pertinent information. 

 
NOTE:  When the “Save Template As….” function is used, the system automatically 
generates a message identifying the original template from which it was created and 
deletes any notes that were on the original template. 
 
Archiving a Template 
 
Only HR Specialist who have “Archiving Privileges” will have the authority to archive the template The 
Template has to be an Approved Template before Archiving.   
Click <Change Status> on the top menu bar.  Select <Approved to Archive> from the main menu.  
Follow the prompts to complete the Archiving process.   

 
Note:   

- HR Specialists should ensure the Template is no longer needed before changing the status to      
Archived Once a Template is archived, the file cannot be manipulated in any way.  Only notes 
can be added.    
- HR Specialists should archive case files as soon as possible after EOD but at least within 90 
days.   

 
Restore Archived JA Template 
 
In an effort to maximize the space within the active server for CPDSS, every Friday JA Templates that 
are marked for “Archived” will be moved from the active server to a “storage server” by the system 
administrators.  Once the Templates are moved, they are no longer accessible to users for viewing or 
copying.  If needed, a request may be submitted to the CPDSS System Administrators, to have a 
Template retrieved from the storage server and brought back to the active server.  Note:  The Archived 
status does not change when the Template is retrieved. 
 
Request should be submitted by e-mail to: thomas.wood@randolph.af.mil AND 
marjorie.roberts@randolph.af.mil   
 



RESUMIX/CPDSS User’s Guide to Filling Jobs 
AFPC/DPCXT, Revised October 2003 
 

4-26

When submitting a request for an Archived JA Template to be retrieved, the following items must be 
included. 

• Full Scoring JA Template Name  
• Approximate date the original JA Template archive took place 
• The exact HR Specialists CPDSS username that archived the original request 
 

Internal Recruitment – (INTERNAL) 
This section covers the steps used to complete a Job Analysis Promotion Plan Template using Skill 
Codes (previously referred as Table 465). 
 
Select <Internal> (from the Template Element area) to display the screen shown below. 
 
To complete the Job Related Skills window: 
 
Step 1:  Creating Element Rules: 
 

• Assign - This field is used to assign the point value to the element rule.  The user would normally 
assign 1 point for basic eligibility.   

 
• Points for – This field allows the user to choose how many occurrences of  skills a candidate must 

match in order for the point value assigned to be applied.  Select from the drop-down menu to 
access the following options: 

 
o ALL – This selection allows the point value to be assigned for the rule only if all of the skills 

selected are matched. 
 
o ANY ONE – This selection allows the point value to be assigned for the rule if any skill 

selected is matched. 
 

o Each – Do NOT USE 
 
o NUMBER – A number can be placed in this field instead of one of the choices from the drop-

down menu.  The number represents how many skill codes must be matched by the 
applicant in order for the applicant to receive the point value for this rule.   (EX: a “2” in this 
area means the candidate must have 2 out of all the skills listed to receive the point value 
assigned) 

 
Step 2:  This window contains a field that requires an “IN” or “NOT IN” option when using Skills Code 
Set.  Select “IN” from the drop-down list when filling from internal sources. 
 
Step 3:  Click the down arrow.  A drop-down menu with the entire Skills Code Table from DCPDS will be 
displayed.  To select Skill Codes, click inside the corresponding box.  Repeat as necessary to select all 
relevant skills needed. 

 
 
 
 
 
 
 
 
 
 
 
 
 

Step 1 
A Number can be 
placed in this field 
instead of making a 
selection from the 
menu. 

Step 2 Step 3
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Step 4:  Repeat Steps 1 through 3 as necessary until you have an adequate amount of rules to identify 

candidates that meet: 
 
  Minimum Qualifications/Basic Eligibility 
  Better Qualified 
  Best Qualified 
 

NOTES:   
 
1.  The Element, Option Internal (Internal) must contain a minimum of at least one Element 

Rule.  It is recommended that no more than five rules be used. 
2. To select multiple skill codes in row, highlight the first desired skill, depress the “shift” 

key, and click the last desired skill.  All intervening skills should be selected. 
3. To deselect a skill, click a second time on the skill and the check will disappear. 
4. With each additional Element Rule, the objective is to build the rules to narrow down to 

identifying best-qualified candidates. 
 
Step 5:  Once the Element Rules are complete, place the number of points assigned to the highest 
Element Rule in the Maximum Points field.  Ex: if 4 points is the highest value assigned then place a 4 in 
the field.  Click on the “Use this element” field.  A check mark will appear in the box.  This is an indicator 
of whether the element is active or inactive in the Job Analysis Promotion Plan Template (must be active 
for the template to work). 
  

Step 5 
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OR and AND Logic: 
 
The “OR Logic” is used as a substitution for one or all Element Rules and the “AND Logic” is used as a 
must have restriction for Element Rule(s) or for the OR Logic area.  Later in this topic we will explain how 
to apply the rules to one data field or to multiple data fields. 
 
The OR and the AND Logic blocks located at the bottom of the (OPT9) Window, consist of the following: 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
NOTE:  The “?” mark located at the top right hand corner of the screen can be use to obtain 
context help screens (like the ones seen above).  Click and drag” the “?” mark to any area on this 
screen to view the context help screens.

(This is a partial list only) 
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Data Field: 
This allows the user to apply a restriction to a specific item(s).  This field extracts data from the tables 
located in DCPDS, Experience History and Resumix databases.  See Attachment 2 (at the end of 
chapter 4) for a listing of options. 
 

Note:  The special selection **CLEAR RESTRICTION** will remove the restriction line 
from the element.  The entire restriction line will be deleted.  

 
Logical Operator: 
Select the desired operator to be applied to the Value field.  This selection must be completed prior to 
input of the Value Set. 
 
Value Set 
Select the appropriate value(s) from the drop-down list if the field is blue.  Otherwise, the value must be 
typed in this field.  See Restriction Value Set information in the above illustration. 
 
Apply To Rule for the “OR Logic” area. (OR Logic is used as a substitution) 
This field allows the user to select the Element Rule(s) that the “OR Logic” applies to.  The restriction 
may be applied to one line number, multiple line numbers or ALL the element rules for which this “Data 
Field” will substitute.  Type the line number in the field, and press the Insert key to add the entered line 
number to the list. Repeat for each additional Element Rule.  Choose the ALL selection to apply the “OR 
Logic” to all of the Element Rule lines.   
 
 
 
 
 
 
 
 
 
Apply to Rule for the “AND Logic” area. (AND Logic is a MANDATORY restriction)  Values are 
entered in the same manner as the “OR Logic”.  The only major difference is in the Apply to Rule/OR 
Logic window. 
 
Apply To Rule/OR Logic 
This field allows you to apply “AND Logic” to the Element Rule(s), the “OR Logic” fields, or a 
combination of the two using one of the following: 
 

• To apply “AND Logic” to Element Rules, type an “R” plus the rule line number and press the 
Insert key. 

• To apply “AND Logic” to “OR Logic” statements, type an “O” plus the “OR Logic” line number and 
press the Insert key. 

• To apply “AND Logic” to all Element Rules select “RULE All” from the drop-down list. 
• To apply “AND Logic” to all “OR Logic” lines select “OR All” from the drop-down list. 
• Simply typing a numeric value will prompt the system to ask if you want to apply this restriction to 

the Element Rule area or the Or Logic area. 
 

 
 
 
 
 
 
 
 
Step 6:  Click <OK>.  This will return you to the Main Job Analysis Promotion Plan Template screen. 
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Saving the Job Analysis Promotion Plan Template 
 
Once the Job Analysis Promotion Plan Template is complete the template should be saved by: 
 

• Clicking File > Save Job Analysis Promotion Plan Template or  
 
 

• Clicking the Save button. 
 
Remember changes can be made to a template that is in a “Test” status, but only by the original creator.  
Once the template is in an approved or archived status, in order to make changes, the template must be 
copied.  To do this, select File > Save Template As, rename the template using the appropriate naming 
convention.  This will create a copy of the template in a test status that can then be modified for 
necessary changes. 
 
 
Entering Template Notes: 
 

• Place your cursor inside the Template Notes Box. 
• Type in the desired comments.  This box can be used to identify Qualification Requirements, 

Education Substitution, TIG, Physical Requirement, Quality of Experience, OPM Standard etc. or 
any other pertinent information. 

 
NOTE:  When the “Save Template As….” function is used, the system automatically generates a 

message identifying the original template from which it was created and deletes any notes that 
were on the original template. 
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Viewing and E-mailing the Job Analysis Report 
 
To e-mail the Job Analysis to the manager for review Click on the Job Analysis/Job Analysis Promotion 
Plan Template Report button.      

 
             
 

 
 
 

The system will prompt you to include the Template Notes with the Report. 
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The Job Analysis Promotion Plan Template Report Preview window (below) will be displayed.  This 
window shows the Best Qualified Description, the Major Job Requirements, the Knowledge, Skills, and 
Abilities (KSAs), the total number of elements in the template, total possible points, element name 
(INTERNAL or (OPT 9), Ranking Criteria, Rules, the AND and/or OR Logic restrictions if applicable and 
the Template Notes. 
 
 
 
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Page 2 of 3 

Page 1 of 3 

Page 3 of 3 
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NOTE:  This document will become a part of the electronic case file. 
 
E-mailing the Job Analysis/Job Analysis Promotion Plan Template Report 
While the Job Analysis Promotion Plan Template Report Preview window is open, click the Export button. 
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The following Export Window will be displayed.  Select “Exchange Folder” from the Destination drop-
down list.  Click <OK>. 
 

 
 
The Choose Profile dialog box will appear.  Click <OK>. 
 

 
 
Select “Inbox” on the Select a Folder dialog box.  Click <OK>. 
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To send the JA/Job Analysis Promotion Plan Template Report directly to the manager for review, with the 

Job Analysis Promotion Plan Template Report Preview window is open, click the Export button.   
 
 

 
 
The following Export window will be displayed.  Select “Microsoft Mail (MAPI)” from the Destination drop-
down list.  Click <OK>. 
 

   
 
The following Send Mail window will be displayed.  Type the email address or click the “address” box to 
pull from the email address list.  The “Message” box can be used to type instructions to the manager.  
When finished click the “Send” box. 
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Chapter 4, Attachment 1 
 

Job Analysis Promotion Plan Element Description 
 
ELEMENT BUTTONS   
 
 DOE = Diversity of Experience 
 STD = Standard 
 OPT = Optional 
 

Non-Career Program Elements 
 

OPT9 – JOB RELATED SKILLS (SKL3) - This Job Analysis Promotion Plan element allows you to check for 
specific job related or technical skills stored in an employee's Resumix skills table and to assign points if the 
employee has any ONE of the skills listed on that line.  Because this option gives points for only the highest value, 
which an employee can meet, it has the effect of "grouping" candidates like a PLF.  (See Optional Element #7 and 
#8 for alternative ways to assign points.) The skills list of values will initially be empty.  To add skills to this list of 
values simply double-click the desired skill in the RESUMIX Knowledge Base window.  You will then see the skill 
in the list of values. 
 
VET – VETERANS PREFERENCE (VET) - This element provides the capability to apply veteran’s preference for 
competitive examining (including DEU and outside-the-register certificates) and noncompetitive certificates 
(including VRA and excepted services). 
 
INTERNAL – INTERNAL RANKING AND RATING - This Job Analysis Promotion Plan element allows you to 
assign levels/points when an employee has worked in a job that has been skills coded with the codes you specify. 
 
 

Career Program Elements 
 
DOE1 – MULTI-COMMAND (MCMD) - This Job Analysis Promotion Plan element counts the number of different 
major commands in which the employee has worked and assigns points for the number found. (CAREER 
PROGRAM ONLY) 
 
DOE2 – MULTI-LEVEL (MLVL) - This Job Analysis Promotion Plan element allows you to assign points for work 
at Headquarters, Major Command, or Base level.  (CAREER PROGRAM ONLY) 
 
DOE3 – MULTI-OCCUPATIONAL SERIES (MOCC) - This Job Analysis Promotion Plan element allows you to 
assign points based on how many different occupational series in which an employee has worked.  (CAREER 
PROGRAM ONLY) 
 
DOE4 – MULTI-OCCUPATIONAL SERIES (OCC2) - This Job Analysis Promotion Plan element allows you to 
assign points based on how many different groupings of occupational series in which an employee has worked.  The 
user decides how to group the occupational series.  (CAREER PROGRAM ONLY) 
 
DOE5  - MULTI-SKILLS (MSKL) -This Job Analysis Promotion Plan element allows you to assign points when an 
employee has worked in a job that has been skills coded with the codes you specify. (CAREER PROGRAM ONLY) 
 
DOE6 – MULTI-ORGANIZATIONAL FUNCTION (MORG) - This Job Analysis Promotion Plan element counts 
the number of different organization structure codes in which an employee has worked and assigns points for the 
number found. (CAREER PROGRAM ONLY) 
 
DOE7 – SUPERVISORY/MANAGERIAL (SUPV) - This Job Analysis Promotion Plan element allows you to 
assign points for supervisory and managerial experience. (CAREER PROGRAM ONLY) 
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STD1 – PROFESSIONAL MILITARY EDUCATION  (PME) - This Job Analysis Promotion Plan element allows 
you to assign points for PME completed by an employee. (CAREER PROGRAM ONLY) 
 
STD2 – PROFESSIONAL CIVILIAN EDUCATION (PCE) - This Job Analysis Promotion Plan element allows you 
to assign points for PCE completed by an employee. (CAREER PROGRAM ONLY) 
 
STD3 – FORMAL EDUCATION (EDUC) - This Job Analysis Promotion Plan element allows you to assign points 
for the highest educational level achieved by the employee (CAREER PROGRAM ONLY) 
 
STD4 – ACADEMIC MAJOR (ACAD) - This Job Analysis Promotion Plan element allows you to assign points for 
having a degree in a specific field of study. (CAREER PROGRAM ONLY) 
 
STD5 – ANNUAL RATING (RATG) - This Job Analysis Promotion Plan element allows you to assign points 
based on the employee's annual rating for the last 3 years.  The formula is fixed, but you can adjust the standard 30 
point maximum value up or down. (CAREER PROGRAM ONLY) 
 
OPT1 – GOVERNMENT TRAINING (TRNG) - This Job Analysis Promotion Plan element allows you to assign 
points for government sponsored training not covered in PME and PCE.  Typically, this would be training related to 
the career field. (CAREER PROGRAM ONLY) 
 
OPT2 – OVERSEAS EXPERIENCE (OSEA) - This Job Analysis Promotion Plan element allows you to assign 
points for overseas experience.  If you wish, you can give more points for overseas experience in a certain major 
command; and lesser points for any other overseas experience by using the "not in" comparator and listing those 
command codes for which you gave greater points. (CAREER PROGRAM ONLY) 
 
OPT3 – PROFESSIONAL/ACQUISITION CERTIFICATIONS (CERT) - This Job Analysis Promotion Plan 
element allows you to assign points for work related certifications. (CAREER PROGRAM ONLY) 
 
OPT4 – AWARDS (AWDS) - This Job Analysis Promotion Plan element allows you to assign varying point values 
for award codes stored in an employee's record. (CAREER PROGRAM ONLY)  
 
OPT5 – MULTI-LOCATIONS (MLOC) - This Job Analysis Promotion Plan element allows you to approximate a 
check for mobility.  You must check and understand location codes stored in registrant records. 
OPT6 – JOINT COMMAND EXPEIRENCE (JNT) - This Job Analysis Promotion Plan element allows you to give 
points for having worked in a joint services command. (CAREER PROGRAM ONLY) 
 
OPT7 – JOB RELATED SKILLS (SKL1) - This Job Analysis Promotion Plan element allows you to check for 
specific job related or technical skills stored in an employee's Resumix skills table and to assign points for each skill 
found.  (See Optional Element #8 and #9 for alternative ways to assign points.) The skills list of values will initially 
be empty.  To add skills to this list of values simply double-click the desired skill in the RESUMIX Knowledge Base 
window.  You will then see the skill in the list of values. (CAREER PROGRAM ONLY) 
 
OPT8 – JOB RELATED SKILLS (SKL2) - This Job Analysis Promotion Plan element allows you to check for 
specific job related or technical skills stored in an employee's Resumix skills table and to assign points if the 
employee has any ONE of the skills listed on that line.  (See Optional Element #7 and #8 for alternative ways to 
assign points.) The skills list of values will initially be empty.  To add skills to this list of values simply double-click 
the desired skill in the RESUMIX Knowledge Base window.  You will then see the skill in the list of values. 
(CAREER PROGRAM ONLY) 
 
OPT9 – JOB RELATED SKILLS (SKL3) - This Job Analysis Promotion Plan element allows you to check for 
specific job related or technical skills stored in an employee's Resumix skills table and to assign points if the 
employee has any ONE of the skills listed on that line.  Because this option gives points for only the highest value, 
which an employee can meet, it has the effect of "grouping" candidates like a PLF.  (See Optional Element #7 and 
#8 for alternative ways to assign points.) The skills list of values will initially be empty.  To add skills to this list of 
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values simply double-click the desired skill in the RESUMIX Knowledge Base window.  You will then see the skill 
in the list of values. 
 
OPT10 – BEHAVIORIAL INVENTORY (BI) - This Job Analysis Promotion Plan element allows you to use a BI 
score as part of the Job Analysis Promotion Plan.  You have only two choices to make.  Identify which BI scoring to 
use from the drop down; and enter the maximum point value.  All scores have been processed using a maximum 
point value of 100 and will be proportionally adjusted up or down to fit the maximum value you select. (CAREER 
PROGRAM ONLY) 
 
OPT11 – INTERVIEW OR MANAGEMENT ASSESSMENT (INTV) - This Job Analysis Promotion Plan element 
allows you to use an Interview score as part of the Job Analysis Promotion Plan.  You have only two choices to 
make.  Identify which Interview Score to use from the drop down; and enter the maximum point value.  All scores 
have been processed using a maximum point value of 100 and will be proportionally adjusted up or down to fit the 
maximum value you select. (CAREER PROGRAM ONLY) 
 
OPT12 – TECHNICAL ASSESSMENT (TA) - This Job Analysis Promotion Plan element allows you to use a TA 
score as part of the Job Analysis Promotion Plan.  To include a TA in a Job Analysis Promotion Plan, check this 
element to be used and enter a maximum value.  These are the only entries to be made here.  When a vacancy is 
being filled, it will be necessary to identify the type of TA which applies and the "weight" values for the TA 
elements applicable to the vacancy.  This is done by entering the TA ID ("C" for contracting, "M" for 
manufacturing, etc.) and the weights for the six (6) supervisory/managerial elements in Resumix Requisition custom 
field "TA TYPE/SUPV"; and by entering the weights for the TA technical elements in Resumix Requisition custom 
field "TA TECHNICAL WEIGHTS".(CAREER PROGRAM ONLY) 
 
OPT13 – NON-FEDERAL EXPERIENCE (NFED) - This Job Analysis Promotion Plan element allows you to give 
points for having non-Federal work experience.  This can include military experience if you wish by including 
experience type code "M" as well as "N".  If the next element is not being used, it can be used to look for a second 
kind of non-Federal work despite its element name. (CAREER PROGRAM ONLY)  
 
OPT 14 – OTHER FEDERAL EXPERIENCE (FEDX) - This Job Analysis Promotion Plan element allows you to 
give points for having other Federal work experience.  This can be non-AF experience or non-DoD experience 
depending on how you use agency codes in your conditional statements.  If the previous element is not being used, it 
can be used to look for a second kind of other Federal work despite its element name. (CAREER PROGRAM 
ONLY) 
 
OPT15 – PROMOTIONS (PROM) - This Job Analysis Promotion Plan element allows you to give points for an 
employee's rate of promotion expressed as how many grade increases have occurred over a specific period of time 
from today's date.  (CAREER PROGRAM ONLY) 
 
VET – VETERANS PREFERENCE (VET) - This element provides the capability to apply veteran’s preference for 
competitive examining (including DEU and outside-the-register certificates) and noncompetitive certificates 
(including VRA and excepted services). 
 
INTERNAL – INTERNAL RANKING AND RATING - This Job Analysis Promotion Plan element allows you to 
assign levels/points when an employee has worked in a job that has been skills coded with the codes you specify. 
 
 
APPR  -  APPRAISAL ELEMENT - This Job Analysis Promotion Plan Template element allows you to use an 
appraisal score as part of the scoring template.  You have four choices to make.  Identify which job family to use 
from the drop down, enter the maximum point value, select the supervisory status, and select the number of years to 
use for appraisal scores.  All scores will be proportionately adjusted against an appraisal consisting of all nines and 
scaled to fit the maximum value you select.  If a supervisory status is not chosen, then it will default to a non-
supervisory status.  If a number of years is not chosen, then only the most current appraisal scores will be used. 
 



RESUMIX/CPDSS User’s Guide to Filling Jobs 
AFPC/DPCXT, Revised October 2003 
 

4-39

 
        Chapter 4, Attachment 2 

 
Job Analysis Promotion Plan Template AND/OR Logic 

 
     

 
 
Internal AND/OR Logic Options:  The following options are appropriate for use when building an 
Internal Job Analysis Promotion Plan Template. 
 
ACQ 1102 Series Qualified 
ACQ Contracting Off Qualified 
ACQ Corp Qualified 
Acquisition Career Level 
Acquisition Position Career 
Appointment Type 
Assignment Command 
Civilian Grade 
DCPDS Education Level 
Demo Broadband 
Demo Pay Plan 
Experience Total Months 
Experience Type 
GSA Geographic Location 
Instructional Program 
Occupational Certificate Date 
Occupational Certificate Kind 
Occupational Series 
Organizational Function Code 
PERM-PAS 
Pay Plan 
Pay Plan and Grade 
Servicing Personnel Office ID 
Skills Code Set 
Steno 
Supervisory Responsibility Level 
Training Program 
Typing Speed 
Vacancy Effective Date 
Work Schedule 
 
 
External AND/OR Logic Options:  The following options are appropriate for use when building 
an External Job Analysis Promotion Plan Template. 
 
Eligibility Status 
High Grade Held 
Resumix Education Level 
Steno 
Typing Speed 
Veterans Preference 
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